基于BGP的企业网互连设计与实现毕业论文 下载本文

interface Serial1/2

ip address 10.4.0.9 255.255.255.252 serial restart-delay 0 clock rate 1008000 router ospf 1

router-id 10.0.0.5

log-adjacency-changes passive-interface Serial1/0 passive-interface Serial1/1 passive-interface Serial1/2 network 10.0.0.5 0.0.0.0 area 0 network 10.0.1.4 0.0.0.3 area 0 network 10.0.1.12 0.0.0.3 area 0 router bgp 65000 no synchronization

bgp log-neighbor-changes

network 10.16.0.0 mask 255.255.255.0 network 10.17.0.0 mask 255.255.255.0 neighbor as65000 peer-group

neighbor as65000 remote-as 65000

neighbor as65000 update-source Loopback0 neighbor as65000 route-reflector-client neighbor as65000 next-hop-self

neighbor 10.0.0.1 peer-group as65000 neighbor 10.0.0.2 peer-group as65000 neighbor 10.0.0.6 remote-as 65000

neighbor 10.0.0.6 update-source Loopback0 neighbor 10.0.0.6 next-hop-self neighbor 10.4.0.2 remote-as 65001

neighbor 10.4.0.2 route-map as65000-in in neighbor 10.4.0.6 remote-as 65002

neighbor 10.4.0.6 route-map as65000-in in neighbor 10.4.0.10 remote-as 65003

neighbor 10.4.0.10 route-map as65000-in in no auto-summary

ip prefix-list p16 seq 5 permit 10.16.0.0/16 ge 24 le 24 ip prefix-list p17 seq 5 permit 10.17.0.0/16 ge 24 le 24 route-map as65000-in permit 10 match ip address prefix-list p16 set local-preference 300

route-map as65000-in permit 20 match ip address prefix-list p17 set local-preference 200

route-map as65000-in permit 30

3

route-map as65000-out permit 10 match ip address prefix-list p16 set metric 1000

route-map as65000-out permit 20 match ip address prefix-list p17 set metric 2000

route-map as65000-out permit 30

BJ-RT2#

interface Loopback0

ip address 10.0.0.6 255.255.255.255 interface Ethernet0/0 description to-sw2

ip address 10.0.1.10 255.255.255.252 interface Ethernet0/1 description to-RT1

ip address 10.0.1.14 255.255.255.252 interface Serial1/0 description to-RT6

ip address 10.4.0.17 255.255.255.252 serial restart-delay 0 clock rate 1008000 interface Serial1/1 description to-RT4

ip address 10.4.0.13 255.255.255.252 serial restart-delay 0 clock rate 1008000 interface Serial1/2 description to-RT8

ip address 10.4.0.21 255.255.255.252 serial restart-delay 0 clock rate 1008000 router ospf 1

router-id 10.0.0.6

log-adjacency-changes passive-interface Serial1/0 passive-interface Serial1/1 passive-interface Serial1/2 network 10.0.0.6 0.0.0.0 area 0 network 10.0.1.8 0.0.0.3 area 0 network 10.0.1.12 0.0.0.3 area 0 router bgp 65000 no synchronization

bgp log-neighbor-changes

4

network 10.16.0.0 mask 255.255.255.0 network 10.17.0.0 mask 255.255.255.0 neighbor as65000 peer-group

neighbor as65000 remote-as 65000

neighbor as65000 update-source Loopback0 neighbor as65000 route-reflector-client neighbor as65000 next-hop-self

neighbor 10.0.0.1 peer-group as65000 neighbor 10.0.0.2 peer-group as65000 neighbor 10.0.0.5 remote-as 65000

neighbor 10.0.0.5 update-source Loopback0 neighbor 10.0.0.5 next-hop-self neighbor 10.4.0.14 remote-as 65001

neighbor 10.4.0.14 route-map as65000-in in neighbor 10.4.0.18 remote-as 65002

neighbor 10.4.0.18 route-map as65000-in in neighbor 10.4.0.22 remote-as 65003

neighbor 10.4.0.22 route-map as65000-in in no auto-summary

ip prefix-list p16 seq 5 permit 10.16.0.0/16 ge 24 le 24 ip prefix-list p17 seq 5 permit 10.17.0.0/16 ge 24 le 24 route-map as65000-in permit 10 match ip address prefix-list p16 set local-preference 200

route-map as65000-in permit 20 match ip address prefix-list p17 set local-preference 300

route-map as65000-in permit 30 route-map as65000-out permit 10 match ip address prefix-list p16 set metric 1000

route-map as65000-out permit 20 match ip address prefix-list p17 set metric 2000

route-map as65000-out permit 30

上海总部核心节点设备配置: SH-SW3#

interface Loopback0

ip address 10.0.0.3 255.255.255.255 interface Ethernet0/0 description to-bangong

ip address 10.16.1.1 255.255.255.0 duplex auto

5

interface Ethernet0/1 description to-rt3

ip address 10.1.1.1 255.255.255.252 duplex auto

interface Ethernet0/2 description to-rt3

ip address 10.1.1.5 255.255.255.252 duplex auto router ospf 1

router-id 10.0.0.3

passive-interface Ethernet0/0 network 10.0.0.3 0.0.0.0 area 0 network 10.1.1.0 0.0.0.3 area 0 network 10.1.1.4 0.0.0.3 area 0 network 10.16.1.0 0.0.0.255 area 0 router bgp 65001

bgp log-neighbor-changes neighbor as65001 peer-group

neighbor as65001 remote-as 65001

neighbor as65001 update-source Loopback0 neighbor as65001 next-hop-self

neighbor 10.0.0.4 peer-group as65001 neighbor 10.0.0.7 peer-group as65001 neighbor 10.0.0.8 peer-group as65001 no auto-summary SH-SW4#

interface Loopback0

ip address 10.0.0.4 255.255.255.255 interface Ethernet0/0

description to-shengchan

ip address 10.17.1.1 255.255.255.0 duplex auto

interface Ethernet0/1 description to-sw3

ip address 10.1.1.2 255.255.255.252 duplex auto

interface Ethernet0/2 description to-rt4

ip address 10.1.1.9 255.255.255.252 router ospf 1

router-id 10.0.0.4

passive-interface Ethernet0/0 network 10.0.0.4 0.0.0.0 area 0 network 10.1.1.0 0.0.0.3 area 0

6

network 10.1.1.8 0.0.0.3 area 0 network 10.17.1.0 0.0.0.255 area 0 router bgp 65001

bgp log-neighbor-changes neighbor as65001 peer-group

neighbor as65001 remote-as 65001

neighbor as65001 update-source Loopback0 neighbor as65001 next-hop-self

neighbor 10.0.0.3 peer-group as65001 neighbor 10.0.0.7 peer-group as65001 neighbor 10.0.0.8 peer-group as65001 no auto-summary

SH-RT3#

interface Loopback0

ip address 10.0.0.7 255.255.255.255 interface Ethernet0/0 description to-SW3

ip address 10.1.1.6 255.255.255.252 interface Ethernet0/1 description TO-RT4

ip address 10.1.1.13 255.255.255.252 interface Serial1/0 description to-RT5

ip address 10.4.0.25 255.255.255.252 serial restart-delay 0 clock rate 1008000 interface Serial1/1 description to-RT1

ip address 10.4.0.2 255.255.255.252 serial restart-delay 0 interface Serial1/2 description to-RT7

ip address 10.4.0.29 255.255.255.252 serial restart-delay 0 clock rate 1008000 router ospf 1

router-id 10.0.0.7

log-adjacency-changes passive-interface Serial1/0 passive-interface Serial1/1 passive-interface Serial1/2 network 10.0.0.7 0.0.0.0 area 0 network 10.1.1.4 0.0.0.3 area 0

7